Back to overview
Downtime

Melon Partners and Payfast Credit and Cheque Card payments | OUTAGE are down

Oct 16 at 04:11pm EEST
Affected services
Melon Partners
Payfast Credit and Cheque Card payments | OUTAGE

Resolved
Oct 16 at 04:13pm EEST

Melon Partners and Payfast Credit and Cheque Card payments | OUTAGE recovered.

Created
Oct 16 at 04:11pm EEST

Melon Partners and Payfast Credit and Cheque Card payments | OUTAGE went down.