Back to overview
Downtime

Melon Partners and Payfast Credit and Cheque Card payments | PARTIAL OUTAGE are down

Nov 26 at 01:19am EET
Affected services
Melon Partners
Payfast Credit and Cheque Card payments | PARTIAL OUTAGE

Resolved
Nov 26 at 01:36am EET

Melon Partners and Payfast Credit and Cheque Card payments | PARTIAL OUTAGE recovered.

Created
Nov 26 at 01:19am EET

Melon Partners and Payfast Credit and Cheque Card payments | PARTIAL OUTAGE went down.